Blame view

share-amp/pom.xml 4.55 KB
8f063e4c0   Jelena Cule   Alfresco SDK proj...
1
2
3
4
  <?xml version="1.0" encoding="UTF-8"?>
  <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
      <modelVersion>4.0.0</modelVersion>
3dacad51f   Ahmed Owian   Updated parent ar...
5
      <artifactId>alfresco-skype-share-amp</artifactId>
8f063e4c0   Jelena Cule   Alfresco SDK proj...
6
7
8
9
10
11
      <name>Alfresco Share AMP Module</name>
      <packaging>amp</packaging>
      <description>This is a sample Alfresco Share AMP project, depended upon by the share WAR module</description>
  
      <parent>
          <groupId>org.alfresco.skype</groupId>
3dacad51f   Ahmed Owian   Updated parent ar...
12
          <artifactId>alfresco-skype-parent</artifactId>
8f063e4c0   Jelena Cule   Alfresco SDK proj...
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
          <version>1.0-SNAPSHOT</version>
      </parent>
  
      <!-- 
          SDK properties have sensible defaults in the SDK parent,
          but you can override the properties below to use another version.
          For more available properties see the alfresco-sdk-parent POM.
         -->
      <properties>
          <!-- Defines the target WAR artifactId to run this amp, only used with the -Pamp-to-war switch
               Allowed values: alfresco | share. In this case it's configured to use OOTB share -->
          <app.amp.client.war.artifactId>share</app.amp.client.war.artifactId>
  
          <!-- Defines the log level used in log4j.properties -->
          <app.log.root.level>WARN</app.log.root.level>
      </properties>
  
      <!-- Following dependencies are needed for compiling Java code in src/main/java; 
           <scope>provided</scope> is inherited for each of the following; 
           for more info, please refer to alfresco-platform-distribution POM -->
      <dependencies>
          <dependency>
              <groupId>${alfresco.groupId}</groupId>
              <artifactId>share</artifactId>
              <version>${alfresco.version}</version>
              <classifier>classes</classifier>
              <scope>provided</scope>
          </dependency>
  
          <dependency>
              <groupId>org.springframework.extensions.surf</groupId>
              <artifactId>spring-surf-api</artifactId>
              <scope>provided</scope>
          </dependency>
  
          <!--===============================================================
              The following dependencies are needed to be able to compile the
              custom functional tests that are based on Page Objects (PO)
              ===============================================================-->
  
          <!-- Bring in the Share Page Objects (PO) used in our functional tests.
               It contains page objects such as LoginPage -->
          <dependency>
              <groupId>${alfresco.groupId}</groupId>
              <artifactId>share-po</artifactId>
              <version>${alfresco.version}</version>
              <scope>test</scope>
          </dependency>
          <!-- Bring in the Share Page Object (PO) Tests that comes with Alfresco. It has
               the org.alfresco.po.share.AbstractTest class that our custom tests extend. -->
          <dependency>
              <groupId>${alfresco.groupId}</groupId>
              <artifactId>share-po</artifactId>
              <version>${alfresco.version}</version>
              <classifier>tests</classifier>
              <scope>test</scope>
  
              <!-- Exclude version 2.39.0 of selenium that does not work with latest FF browsers, we include
                 version 2.45 later on here -->
              <exclusions>
                  <exclusion>
                      <groupId>org.seleniumhq.selenium</groupId>
                      <artifactId>selenium-java</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.seleniumhq.selenium</groupId>
                      <artifactId>selenium-server</artifactId>
                  </exclusion>
              </exclusions>
          </dependency>
          <!-- Bring in newer selenium version -->
          <dependency>
              <groupId>org.seleniumhq.selenium</groupId>
              <artifactId>selenium-java</artifactId>
              <version>2.45.0-alfresco</version>
              <scope>test</scope>
          </dependency>
          <!-- Test NG is defined with test scope in share-po, so need it here too -->
          <!-- Alfresco code creates a wrapper around Test NG -->
          <dependency>
              <groupId>org.alfresco.test</groupId>
              <artifactId>alfresco-testng</artifactId>
              <version>1.1</version>
              <scope>test</scope>
              <exclusions>
                  <exclusion>
                      <groupId>org.hamcrest</groupId>
                      <artifactId>hamcrest-core</artifactId>
                  </exclusion>
              </exclusions>
          </dependency>
  
      </dependencies>
  
  </project>